PHP sana va vaqt ma’lumotnomasi
PHP sana/vaqt bilan tanishtirish
Sana/vaqt funksiyalari PHP skriptingiz ishlaydigan serverdan sana va vaqtni olish imkonini beradi. Keyin sana va vaqtni bir necha usulda formatlash uchun sana/vaqt funksiyalaridan foydalanishingiz mumkin.
Eslatma: Bu funksiyalar serveringizning mahalliy sozlamalariga bog‘liq. Ushbu funksiyalar bilan ishlashda yozgi vaqtni va kabisa yillarini hisobga olishni unutmang.
O‘rnatish
PHP sana/vaqt funksiyalari PHP yadrosining bir qismidir. Ushbu funksiyalardan foydalanish uchun o‘rnatish talab qilinmaydi.
Ish vaqti konfiguratsiyasi
Ushbu funksiyalarning ishlashiga php.ini sozlamalari ta’sir qiladi:
| Name | Tavsif | Default | PHP Version |
|---|---|---|---|
| date.timezone | Standart vaqt mintaqasi (barcha sana/vaqt funksiyalari tomonidan ishlatiladi) | "" | PHP 5.1 |
| date.default_latitude | Standart kenglik (date_sunrise() va date_sunset() tomonidan ishlatiladi) | "31.7667" | PHP 5.0 |
| date.default_longitude | Standart uzunlik (data_sunrise() va date_sunset() tomonidan ishlatiladi) | "35.2333" | PHP 5.0 |
| date.sunrise_zenith | Standart quyosh natijasi zenit (date_sunrise() va date_sunset() tomonidan ishlatiladi) | "90.83" | PHP 5.0 |
| date.sunset_zenith | Standart quyosh botishi zenit (date_sunrise() va date_sunset() tomonidan ishlatiladi) | "90.83" | PHP 5.0 |
PHP sana/vaqt funksiyalari
| Function | Tavsif |
|---|---|
| checkdate() | Grigorian sanasini tekshiradi |
| date_add() | Sanaga kunlar, oylar, yillar, soatlar, daqiqalar va soniyalarni qo‘shadi |
| date_create_from_format() | Belgilangan formatga muvofiq formatlangan yangi DateTime obyektini qaytaradi |
| date_create() | Yangi DateTime obyektini qaytaradi |
| date_date_set() | Yangi sanani o‘rnatadi |
| date_default_timezone_get() | Barcha sana/vaqt funksiyalari tomonidan ishlatiladigan standart vaqt mintaqasini qaytaradi |
| date_default_timezone_set() | Barcha sana/vaqt funksiyalari tomonidan ishlatiladigan standart vaqt mintaqasini o‘rnatadi |
| date_diff() | Ikki sana orasidagi farqni qaytaradi |
| date_format() | Belgilangan formatga muvofiq formatlangan sanani qaytaradi |
| date_get_last_errors() | Sana stringida topilgan ogohlantirishlar/xatolarni qaytaradi |
| date_interval_create_from_date_string() | Stringning nisbiy qismlaridan DateInterval yaratadi |
| date_interval_format() | Intervalni formatlaydi |
| date_isodate_set() | ISO sanasini o‘rnatadi |
| date_modify() | Vaqt belgisini (timestamp) o‘zgartiradi |
| date_offset_get() | Vaqt mintaqasi ofsetini qaytaradi |
| date_parse_from_format() | Belgilangan formatga muvofiq, belgilangan sana haqida batafsil ma’lumotga ega assotsiativ massivni qaytaradi |
| date_parse() | Belgilangan sana haqida batafsil ma’lumotga ega assotsiativ massivni qaytaradi |
| date_sub() | Sanadan kunlar, oylar, yillar, soatlar, daqiqalar va soniyalarni ayiradi |
| date_sun_info() | Belgilangan kun va joy uchun quyosh botishi/natijasi va alacakaranlık boshlanishi/tugashi haqidagi ma’lumotlarni o‘z ichiga olgan massivni qaytaradi. |
| date_sunrise() | Eskirgan. Belgilangan kun va joy uchun quyosh natija vaqtini qaytaradi |
| date_sunset() | Eskirgan. Belgilangan kun va joy uchun quyosh botishi vaqtini qaytaradi |
| date_time_set() | Vaqtni belgilaydi |
| date_timestamp_get() | Unix vaqt tamg‘asini qaytaradi |
| date_timestamp_set() | Unix vaqt tamg‘asi asosida sana va vaqtni o‘rnatadi |
| date_timezone_get() | Berilgan DateTime obyektining vaqt mintaqasini qaytaradi |
| date_timezone_set() | DateTime obyekti uchun vaqt mintaqasini o‘rnatadi |
| date() | Mahalliy sana va vaqtni formatlaydi |
| getdate() | Vaqt tamg‘asi yoki joriy mahalliy sana/vaqtning sana/vaqt ma’lumotlarini qaytaradi |
| gettimeofday() | Joriy vaqtni qaytaradi |
| gmdate() | GMT/UTC sana va vaqtini formatlaydi |
| gmmktime() | GMT sanasi uchun Unix vaqt tamg‘asini qaytaradi |
| gmstrftime() | Eskirgan. GMT/UTC sana va vaqtini mahalliy sozlamalarga muvofiq formatlaydi |
| idate() | Mahalliy vaqt/sanani butun son sifatida formatlaydi |
| localtime() | Mahalliy vaqtni qaytaradi |
| microtime() | Mikrosoniyalar bilan joriy Unix vaqt tamg‘asini qaytaradi |
| mktime() | Sana uchun Unix vaqt tamg‘asini qaytaradi |
| strftime() | Eskirgan. Mahalliy vaqt va/yoki sanani mahalliy sozlamalarga muvofiq formatlaydi |
| strptime() | Eskirgan. strftime() yordamida yaratilgan vaqt/sanani tahlil qiladi |
| strtotime() | Inglizcha matn ko‘rinishidagi sana-vaqtni Unix vaqt belgisiga (timestamp) aylantiradi |
| time() | Joriy vaqtni Unix vaqt tamg‘asi sifatida qaytaradi |
| timezone_abbreviations_list() | dst, ofset va vaqt mintaqasi nomini o‘z ichiga olgan assotsiativ massivni qaytaradi |
| timezone_identifiers_list() | Barcha vaqt mintaqasi identifikatorlari bilan indekslangan massivni qaytaradi |
| timezone_location_get() | Belgilangan vaqt mintaqasi uchun joylashuv ma’lumotlarini qaytaradi |
| timezone_name_from_ abbr() | Qisqartirishdan vaqt mintaqasi nomini qaytaradi |
| timezone_name_get() | Vaqt mintaqasining nomini qaytaradi |
| timezone_offset_get() | GMT dan vaqt mintaqasi ofsetini qaytaradi |
| timezone_open() | Yangi DateTimeZone obyektini yaratadi |
| timezone_transitions_get() | Vaqt mintaqasi uchun barcha o‘tishlarni qaytaradi |
| timezone_version_get() | Timezonedb versiyasini qaytaradi |
PHP oldindan belgilangan sana/vaqt konstantalari
| Constant | Tavsif |
|---|---|
| DATE_ATOM | Atom (misol: 2019-01-18T14:13:03+00:00) |
| DATE_COOKIE | HTTP Cookies (misol: Fri, 18 Jan 2019 14:13:03 UTC) |
| DATE_ISO8601 | ISO-8601 (misol: 2019-01-18T14:13:03+0000) |
| DATE_RFC822 | RFC 822 (misol: Fri, 18 Jan 2019 14:13:03 +0000) |
| DATE_RFC850 | RFC 850 (misol: Friday, 18-Jan-19 14:13:03 UTC) |
| DATE_RFC1036 | RFC 1036 (misol: Friday, 18-Jan-19 14:13:03 +0000) |
| DATE_RFC1123 | RFC 1123 (misol: Fri, 18 Jan 2019 14:13:03 +0000) |
| DATE_RFC2822 | RFC 2822 (misol: Fri, 18 Jan 2019 14:13:03 +0000) |
| DATE_RFC3339 | DATE_ATOM bilan bir xil (PHP 5.1.3 dan beri) |
| DATE_RFC3339_EXTENDED | RFC3339 kengaytirilgan formati (PHP 7.0.0 dan beri) (misol: 2019-01-18T16:34:01.000+00:00) |
| DATE_RSS | RSS (Fri, 18 Jan 2019 14:13:03 +0000) |
| DATE_W3C | World Wide Web Consortium (misol: 2019-01-18T14:13:03+00:00) |
| SUNFUNCS_RET_TIMESTAMP | Timestamp (since PHP 5.1.2) |
| SUNFUNCS_RET_STRING | Soat:daqiqa (misol: 09:41) (PHP 5.1.2 dan beri) |
| SUNFUNCS_RET_DOUBLE | O‘zgaruvchan nuqtali raqam sifatida soatlar (misol: 9,75) (PHP 5.1.2 dan beri) |
W3Schools Pathfinder
Yutuqlaringizni kuzating – bu bepul!
