gmdate()

PHP gmdate() funksiyasi

❮ PHP sana va vaqt ma’lumotnomasi

Misol

GMT/UTC sana va vaqtini formatlang hamda formatlangan sana stringlarini qaytaring:

<?php // Prints the day echo gmdate("l") . "<br>"; // Prints the day, date, month, year, time, AM or PM echo gmdate("l jS \of F Y h:i:s A"); ?>
O‘zingiz sinab ko‘ring »

ULASHISH

Ta’rif va qo‘llanilishi

gmdate() funksiyasi GMT/UTC sana va vaqtini formatlaydi hamda formatlangan sana stringini qaytaradi.


Sintaksis

gmdate(format, timestamp)

Parametr qiymatlari

Parametr Tavsif
format Majburiy. Chiqariladigan sana stringining formatini belgilaydi. Quyidagi belgilardan foydalanish mumkin:
  • d - Oyning kuni (01 dan 31 gacha)
  • D - Kunning matnli ko‘rinishi (uchta harf)
  • j - Boshida nolsiz oyning kuni (1 dan 31 gacha)
  • l (kichik 'L' harfi) - Kunning to‘liq matnli ko‘rinishi
  • N - Kunning ISO-8601 bo‘yicha sonli ko‘rinishi (1 - dushanba, 7 - yakshanba)
  • S - Oy kuni uchun inglizcha tartib qo‘shimchasi (2 ta belgi: st, nd, rd yoki th. j bilan yaxshi ishlaydi)
  • w - Kunning sonli ko‘rinishi (0 - yakshanba, 6 - shanba)
  • z - Yilning kuni (0 dan 365 gacha)
  • W - Yildagi haftaning ISO-8601 bo‘yicha raqami (haftalar dushanbadan boshlanadi)
  • F - Oyning to‘liq matnli ko‘rinishi (January dan December gacha)
  • m - Oyning sonli ko‘rinishi (01 dan 12 gacha)
  • M - Oyning qisqa matnli ko‘rinishi (uchta harf)
  • n - Oyning boshida nolsiz sonli ko‘rinishi (1 dan 12 gacha)
  • t - Berilgan oydagi kunlar soni
  • L - Kabisa yili ekanligi (kabisa yili bo‘lsa 1, aks holda 0)
  • o - ISO-8601 bo‘yicha yil raqami
  • Y - Yilning to‘rt xonali ko‘rinishi
  • y - Yilning ikki xonali ko‘rinishi
  • a - Kichik harflarda am yoki pm
  • A - Katta harflarda AM yoki PM
  • B - Swatch Internet vaqti (000 dan 999 gacha)
  • g - Soatning 12 soatlik formati (1 dan 12 gacha)
  • G - Soatning 24 soatlik formati (0 dan 23 gacha)
  • h - Soatning 12 soatlik formati (01 dan 12 gacha)
  • H - Soatning 24 soatlik formati (00 dan 23 gacha)
  • i - Boshida nol bilan daqiqalar (00 dan 59 gacha)
  • s - Boshida nol bilan soniyalar (00 dan 59 gacha)
  • u - Mikrosoniyalar (PHP 5.2.2 da qo‘shilgan)
  • e - Vaqt mintaqasi identifikatori (Misollar: UTC, GMT, Atlantic/Azores)
  • I (katta i harfi) - Sana yozgi vaqtga to‘g‘ri kelishi (yozgi vaqt bo‘lsa 1, aks holda 0)
  • O - Grinvich vaqtidan (GMT) farq, soatlarda (Misol: +0100)
  • P - Grinvich vaqtidan (GMT) farq, soat:daqiqa ko‘rinishida (PHP 5.1.3 da qo‘shilgan)
  • T - Vaqt mintaqasi qisqartmalari (Misollar: EST, MDT)
  • Z - Vaqt mintaqasi ofseti soniyalarda. UTC dan g‘arbdagi vaqt mintaqalari uchun ofset manfiy bo‘ladi (-43200 dan 50400 gacha)
  • c - ISO-8601 formatidagi sana (masalan, 2013-05-05T16:34:42+00:00)
  • r - RFC 2822 formatidagi sana (masalan, Fri, 12 Apr 2013 12:01:05 +0200)
  • U - Unix davri (Epoch) boshidan (1970-yil 1-yanvar 00:00:00 GMT) beri o‘tgan soniyalar

shuningdek, quyidagi oldindan belgilangan konstantalardan ham foydalanish mumkin (PHP 5.1.0 dan beri mavjud):

  • DATE_ATOM - Atom (misol: 2013-04-12T15:52:01+00:00)
  • DATE_COOKIE - HTTP Cookies (misol: Friday, 12-Apr-13 15:52:01 UTC)
  • DATE_ISO8601 - ISO-8601 (misol: 2013-04-12T15:52:01+0000)
  • DATE_RFC822 - RFC 822 (misol: Fri, 12 Apr 13 15:52:01 +0000)
  • DATE_RFC850 - RFC 850 (misol: Friday, 12-Apr-13 15:52:01 UTC)
  • DATE_RFC1036 - RFC 1036 (misol: Fri, 12 Apr 13 15:52:01 +0000)
  • DATE_RFC1123 - RFC 1123 (misol: Fri, 12 Apr 2013 15:52:01 +0000)
  • DATE_RFC2822 - RFC 2822 (Fri, 12 Apr 2013 15:52:01 +0000)
  • DATE_RFC3339 - DATE_ATOM bilan bir xil (PHP 5.1.3 dan beri)
  • DATE_RSS - RSS (Fri, 12 Aug 2013 15:52:01 +0000)
  • DATE_W3C - World Wide Web Consortium (misol: 2013-04-12T15:52:01+00:00)
timestamp Ixtiyoriy. Butun sonli Unix vaqt tamg‘asini belgilaydi. Standart qiymat — joriy mahalliy vaqt (time())


Texnik tafsilotlar

Qaytariladigan qiymat: Muvaffaqiyatli bo‘lsa formatlangan sana stringini qaytaradi. Muvaffaqiyatsiz bo‘lsa FALSE + E_WARNING
PHP versiyasi: 4+
PHP o‘zgarishlar tarixi: PHP 5.1: Vaqt tamg‘asining yaroqli oralig‘i endi Fri, 13 Dec 1901 20:45:54 GMT dan Tue, 19 Jan 2038 03:14:07 GMT gacha. 5.1 versiyasidan oldin ayrim tizimlarda (masalan, Windows) vaqt tamg‘asi 01-01-1970 dan 19-01-2038 gacha bo‘lgan oraliq bilan cheklangan edi.
PHP 5.1.1: format parametrini belgilash uchun ishlatilishi mumkin bo‘lgan standart sana/vaqt formatlari konstantalari qo‘shildi

❮ PHP sana va vaqt ma’lumotnomasi

W3Schools Pathfinder

Yutuqlaringizni kuzating – bu bepul!